강의로 돌아가기
교육운영자 에밀리

12강의 babel-loader 오류 관련 공지

babel-loader 오류 관련 공지

지속적으로 babel 오류에 대한 문의가 있습니다. 최근 babel이 업데이트 되면서 생기는 문제로 보입니다.
.babelrcstage 정보를 넣지 않는 등 많은 부분에 변화가 있어 babel-loader관련 이슈가 생길 시에 수강생분들께서는 다음의 과정을 진행해 주시기 바랍니다.

현재 시점에서 해결하시는 방법은 babelrc를 새로운 문법으로 업그레이드 하시는 방법인데요. 진행 순서는 아래와 같습니다.

1. babel-upgrade 를 설치합니다. sudo npm i -g babel-upgrade (관리자 권한으로 전역설치를 하셔야 합니다.)
2. babel-upgrade 툴로 package.json과 .babelrc를 업데이트 합니다. babel-upgrade --write (실행하면 위의 두 파일이 변경됩니다.)
3. 변경된 패키지로 새로 설치를 합니다. npm i
4. npm run serve 를 통해 동작을 확인합니다.

1 개의 답변
Demi

관련 오류를 계속 경험하는 분께서는 댓글을 달아주세요.

답변 쓰기
이 입력폼은 마크다운 문법을 지원합니다. 마크다운 가이드 를 참고하세요.