강의로 돌아가기
황남익

GetComponent 관련해서 질문이 있습니다.

강의 잘 보고 있습니다.

풀어쓰기 이전의 코드가
gameObject.GetComponent().AddForce(Vector3.up300);
가 아니고, GetComponent().AddForce(Vector3.up
300);
인 것으로 보아 제 생각에는 풀어 쓰는 부분도

ballRigid = gameObject.GetComponent();
가 아니라 ballRigid = GetComponent();
가 되야 한다고 생각하는데 무엇이 더 좋은 코드인 것인가요?

이전 강의에서 'Part4'의 GetComponent쓰기부분을 복습했었는데 거기서
Rigidbody의 형태를 가져올 때는 앞에 gameObject를 쓰지 않았던 것으로 기억해서요
찾아보니까 'GetComponent쓰기' 강의에서는 3:16부분에서는 gameObject를 쓰지 않았습니다.

1 개의 답변
정두식_

어떻게 해도 상관은 없을것 같아요. 더 좋은 코드라기 보다는 선호의 문제인것 같습니다. 다만 일관성만 있으면 좋겠어요.

저는 같은 코드라면 짧은편을 선호하는 편이긴 합니다. 길면 읽기도 그렇고 치기도 그렇고 귀찮으니까요.

답변 쓰기
이 입력폼은 마크다운 문법을 지원합니다. 마크다운 가이드 를 참고하세요.